VIM编译新版本

本来打算在一台Linux虚拟机里安装个YouCompleteMe,结果出现了一行requirement惊呆了我

YouCompleteMe unavailable: requires Vim 7.4.143+

这不才只要7.3.xxx版本以上,突然偶要7.4以上了,偏偏源里安装的vim版本不够,只要手工编译一把

这里有需要一些python的依赖,具体可以vim –version看来下pyth[……]

Read more

YouCompleteMe:永远相信美好的事情即将发生

对于VIM插件YouCompleteMe,最近比较纠结,这名字倒是取得相当顺眼,就是安装起来太顽强了

1:Cygwin

如果想Cygwin上安装,建议放弃,我在编译得离成功最近的一步的时候,由于Boost的一些库文件很多ifdef指定了操作系统以及头文件路径,与linux基本一致,但是cygwin毕竟类linux工具,差异还是很大的,改了很多boost的头文件内容,添加对cygwin的兼容,但是错[……]

Read more